VS loadtest Ergebnisse werden nicht in den DB auf Build Agent geschrieben

Ich habe ein Load Test Repository in meinem lokalen Rechner SQL DB mit loadtestresultsrepository.sql Skript. Dann geänderte Verbindungszeichenfolge von der Standard-SQL server Express lokalen db auf die, die ich wollte die Testergebnisse mit dem Management Test Controllers windows zu speichern. Dann lief ich den Test mit VS, MSTest Befehlszeile und Powershell lokal und Ergebnisse wurden an die DB erfolgreich geschrieben.

Ich wollte das gleiche Ergebnis auf TFS 2015 Build Agent zu erreichen, so dass ich die Last und Performance-Test auf dem CI-server laufen konnte. Als ich den Lasttest auf CI-server mit einer Build-Definition, die Befehlszeile verwendet mstest Aufgabe /TestContainer:$(build.sourcesDirectory)\$(Component)\LoadTests\20_Users.loadtest \ /TestContainer:$(build.sourcesDirectory)\$(Component)\LoadTests\20_Users.loadtest , es schrieb keine data auf Standard (localdb)\v11.0 server. Aber der Lasttest lief erfolgreich. I RDP an den Build-Agenten, öffne die Lösung aus zuvor kopierten Build-Artefakten und setze die Verbindungszeichenfolge auf den SQL server DB auf dem Build-Agenten unter Verwendung von Test Controllers-windows. Auch erstellt Last Test Repository auf Build Agent als auch. Aber Last Testergebnisse werden nicht in die DB geschrieben, wenn ich die Tests mit Build-Definition laufen.Wenn ich den gleichen mstest Befehl mit powershell oder cmd Aufforderung auf Build Agent ausführen, schreibt er die Ergebnisse. Kann mir jemand helfen. Wie bekomme ich die Build-Definition / Test-Controller, um die data an die DB zu schreiben, die ich im Build-Agenten konfiguriert habe?